Update

Incident Report for Yoti

Resolved

This issue is resolved now.
Posted Mar 22, 2024 - 01:20 UTC

Monitoring

We are experiencing a high volume of requests through our systems at the moment, some requests may take longer than normal
Posted Mar 22, 2024 - 00:48 UTC
This incident affected: Global (Digital ID, Identity verification).