Yoti App Temporarily Unavailable for Download on Google Play Store
Incident Report for Yoti
Resolved
Yoti App available for Download on Google Play Store. This incident has been resolved.
Posted Jan 04, 2022 - 08:10 UTC
Identified
The Yoti App is temporarily unavailable for download from the Google Play Store. The issue has been identified and we are working with Google to reinstate the app back on the PlayStore at the earliest and this page will be updated as we find out more.
Posted Dec 31, 2021 - 15:39 UTC
This incident affected: Global (Digital ID).