Our engineers have rolled out a fix for the Identity verification & Age estimation service, which is currently propagating. We are already observing initial signs of recovery, and our team will continue to monitor system stability closely before officially resolving the incident.
Posted Sep 15, 2026 - 04:57 UTC
Identified
We have identified the root cause of the issues affecting the Identity verification & Age estimation service. Our team is actively working on a fix to restore full functionality as quickly as possible.
Posted Sep 15, 2026 - 04:57 UTC
Update
We are continuing to troubleshoot the issue with the Identity verification & Age estimation service. Our team is exploring several potential causes, and we will provide another update in 60 minutes.
Posted Sep 15, 2026 - 04:01 UTC
Update
We are continuing to troubleshoot the issue with the Identity verification & Age estimation service. Our team is exploring several potential causes, and we will provide another update in 60 minutes.
Posted Sep 15, 2026 - 03:01 UTC
Investigating
We are currently investigating an issue affecting the Identity verification & Age estimation service. Some customers may experience intermittent performance or downtime.
Posted Sep 15, 2026 - 02:26 UTC
This incident affects: USA1 (Identity verification, Age estimation).