INC-2577
Incident Report for Yoti
Resolved
The services are fully operational. This incident has been resolved.
Posted Aug 06, 2021 - 10:43 UTC
Investigating
At 10:22UTC we experienced performance issues with Identity verification and eSignatures services.
Posted Aug 06, 2021 - 10:42 UTC
This incident affected: Global (Identity verification, eSignatures).