INC-3037 (P2 - Medium Priority)
Incident Report for Yoti
Postmortem

Friday 31st May 2024 from 04:16 UTC - 11:21 UTC

We experienced an exceptionally busy period and some checks for Digital ID & Identity verification were taking longer than normal. 

No customers checks failed to complete but some were unavoidably delayed, this was due to a third party issue. 

Once the third party issue was resolved, our teams worked hard to resolve any outstanding checks as quickly as possible.

We apologise for any inconvenience this outage has caused our customers.

Posted Jun 03, 2024 - 07:07 UTC

Resolved
The Digital ID & Identity verification services are fully operational. This incident has been resolved.
Posted May 31, 2024 - 11:24 UTC
Update
We are continuing to monitor for any further issues.
Posted May 31, 2024 - 09:38 UTC
Monitoring
We are exceptionally busy and some checks for Digital ID & Identity verification are taking longer than normal.
Posted May 31, 2024 - 09:02 UTC
This incident affected: Global (Digital ID, Identity verification).