Jersey Postcode Lookup
Incident Report for Yoti
Resolved
Verifying identity for users in the country of Jersey is fully operational. This incident has been resolved.
Posted Jun 21, 2022 - 08:54 UTC
Identified
We are experiencing issues verifying identity for users in the country of Jersey. All other services are working as expected.
Posted Jun 20, 2022 - 16:09 UTC
This incident affected: Global (Digital ID, Identity verification).