INC-2640

Incident Report for Yoti

Resolved

This incident has been resolved.
Posted May 25, 2022 - 16:12 UTC

Monitoring

The Identity verification service is now fully operational.
Posted May 25, 2022 - 15:48 UTC

Investigating

We are experiencing heavy traffic than usual on the Identity verification service. Users may experience some slowness.
Posted May 25, 2022 - 15:41 UTC
This incident affected: Global (Identity verification).