INC-3388 (P2 - Medium Priority)

Incident Report for Yoti

Postmortem

Tuesday 2nd September 2025 from 12:10 UTC - 14:40 UTC

We're writing to inform you about a service interruption that impacted some customers using our Identity Verification and Digital ID services.

Our Network Operations Center (NOC) noticed a few errors and quickly escalated the issue to our product teams. It was determined that the root cause was an issue with a third-party integration.

This would have only affected specific fraud checks. Some of these checks would have automatically retried, while in other cases, customers may have seen an error message.

We apologise for any inconvenience this outage has caused our customers.

Posted Sep 02, 2025 - 15:34 UTC

Resolved

The Digital ID Identity verification and service is fully operational. This incident has been resolved.
Posted Sep 02, 2025 - 14:47 UTC

Monitoring

We have fixed the Identity verification and Digital ID service. Our engineers will monitor the situation until we declare the incident resolved.
Posted Sep 02, 2025 - 14:31 UTC

Identified

We have identified the cause of this incident and we are working to restore the IDV and Digital ID Services service as soon as possible.
Posted Sep 02, 2025 - 14:01 UTC

Investigating

We are experiencing issues with Identity Profile checks whilst using the IDV and Digital ID Services.
Posted Sep 02, 2025 - 13:37 UTC
This incident affected: Global (Digital ID, Identity verification).