INC-2673
Incident Report for Yoti
Resolved
The Digital ID and Identity verification services are fully operational. The services were impacted between 05:07 and 07:10 UTC.
Posted Oct 12, 2022 - 07:10 UTC
Investigating
We are experiencing issues with the Digital ID and Identity verification services.
Posted Oct 12, 2022 - 05:07 UTC
This incident affected: Global (Digital ID, Identity verification).