INC-3820 (P2- Medium Priority)

Incident Report for Yoti

Resolved

All affected services are now fully operational. The incident has been successfully resolved and all systems are stable. Thank you for your patience.
Posted Aug 12, 2026 - 16:00 UTC

Monitoring

A fix has been implemented for the Identity verification , Identity verification portal, Age verification, eSignatures, and Yoti-Hub services and we are seeing signs of recovery. Our team will continue to monitor the system closely to ensure stability before officially resolving the incident.
Posted Aug 12, 2026 - 15:55 UTC

Identified

We have identified the root cause of the issues affecting Identity verification , Identity verification portal, Age verification, eSignatures, and Yoti-Hub service service. Our team is actively working on a fix to restore full functionality as quickly as possible.
Posted Aug 12, 2026 - 15:54 UTC

Investigating

We are currently investigating an issue affecting Identity verification , Identity verification portal, Age verification, eSignatures, and Yoti-Hub service. Some customers may experience intermittent performance or downtime.
Posted Aug 12, 2026 - 15:45 UTC
This incident affected: Global (Identity verification, Identity verification portal, Age verification, eSignatures, Yoti Hub).