INC-2877
Incident Report for Yoti
Resolved
The services are fully operational. This incident has been resolved.

We would like to apologise as some customers may have experienced errors whilst using or registering for Yoti's Digital ID, Identity Verification, and Age Verification services.
Posted Nov 10, 2023 - 12:58 UTC
Monitoring
We have fixed the Digital ID, Identity verification, and Age verification services. Our engineers will monitor the situation until we declare the incident resolved.
Posted Nov 10, 2023 - 12:51 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 10, 2023 - 12:47 UTC
Update
We are experiencing issues with the Digital ID, Identity verification, and age verification services.
Posted Nov 10, 2023 - 12:30 UTC
Investigating
We are experiencing issues with the Digital ID service.
Posted Nov 10, 2023 - 12:27 UTC
This incident affected: Global (Digital ID, Identity verification, Age verification).