Delay in customer communication

Incident Report for Yoti

Resolved

The issue has now been resolved and any outstanding emails will slowly filter through to our customer service team.

Please be aware this may cause some delays in responding and we appreciate your understanding.
Posted Jun 12, 2025 - 17:32 UTC

Monitoring

Please be aware that our customer service team at Yoti are currently experiencing a delay in message delivery from customers due to an ongoing issue with Salesforce.

We want to assure you we will endeavour to reply to all messages as soon as they are received.

We appreciate your patience and understanding during this time.

https://status.salesforce.com/generalmessages/10001544
Posted Jun 12, 2025 - 14:30 UTC