INC-3479 (P1- High Priority)

Incident Report for Yoti

Postmortem

Wednesday 29th October 14:28 - 15:05 UTC

We are writing to inform you about a temporary service interruption that affected all Yoti services in the USA earlier today.

Our Network Operations Center (NOC) detected an increase in error rates starting at 14:28 UTC.

Our investigation determined the root cause was due to a routine backend migration that caused an unexpected issue which resulted in some of our services becoming temporarily unavailable.

During the incident, some customers may have experienced errors, delays or unable to access Yoti services during this time.

We sincerely apologise for the inconvenience and disruption this outage may have caused. We are conducting a full investigation to identify improvements and prevent future recurrence.

Follow-up:

On further inspection, we can confirm that our Age Verification and Age Estimation services were not impacted by the service interruption that occurred yesterday, Wednesday, 29th October, between 14:28 and 15:05 UTC.

Posted Oct 29, 2025 - 17:11 UTC

Resolved

The Identity verification Age verification Age estimation service is fully operational. This incident has been resolved.
Posted Oct 29, 2025 - 15:05 UTC

Monitoring

We have fixed our services. Our engineers will monitor the situation until we declare the incident resolved.
Posted Oct 29, 2025 - 15:03 UTC

Identified

We have identified the cause of this incident, and we are working to restore the Identity verification, Age verification, and Age estimation services as soon as possible.
Posted Oct 29, 2025 - 14:50 UTC

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 14:40 UTC

Investigating

We are experiencing issues with the Identity verification, Age verification and Age estimation services for the USA region.
Posted Oct 29, 2025 - 14:28 UTC
This incident affected: USA1 (Identity verification, Age verification, Age estimation).