INC-3762 (P1 - High Priority)

Incident Report for Yoti

Postmortem

Monday 22nd June 2026 from 14:52 UTC - 15:10 UTC

We are writing to provide an update regarding a brief service interruption that impacted Yoti systems earlier today.

Our monitoring systems alerted us to an elevated error rate within our Age Verification Service. Immediate investigation isolated the issue to a temporary fault in one of our databases, resulting in a brief period of unavailability our users.

Our team has fully mitigated the root cause, and all services have returned to normal operating parameters. 

Please accept our sincere apologies for the impact on your operations. A rigorous post-mortem review is currently underway to safeguard our infrastructure against future recurrences.

Posted Jun 22, 2026 - 16:30 UTC

Resolved

The Age verification service is now fully operational. The incident has been successfully resolved and all systems are stable. Thank you for your patience.
Posted Jun 22, 2026 - 15:10 UTC

Identified

We have identified the root cause of the issues affecting the Age verification service. Our team is actively working on a fix to restore full functionality as quickly as possible.
Posted Jun 22, 2026 - 14:52 UTC
This incident affected: Global (Age verification).