INC-3472 (P1 - High Priority)

Incident Report for Yoti

Postmortem

Thursday 23rd October 2025 14:47 UTC - 16:54 UTC

We are writing to inform you about a temporary service interruption that affected all Yoti services earlier today.

Our Network Operations Center (NOC) detected an increase in error rates starting at 14:47 UTC. Our investigation determined the root cause was an unexpected issue with a load balancer, which caused our services to become temporarily unavailable.

Timeline of Impact

During the incident, customers may have experienced errors and been unable to access Yoti services during the following periods:

  • 14:47 – 15:06 UTC
  • 15:48 – 15:56 UTC

Although our Infrastructure team quickly resolved the primary problem, we continued to see minor errors affecting IPv6 traffic. Full service was officially restored at 16:54 UTC

We sincerely apologise for the inconvenience and disruption this outage may have caused.

We are conducting a full investigation to identify improvements and prevent future recurrence.

Posted Oct 23, 2025 - 18:26 UTC

Resolved

All services is fully operational. This incident has been resolved.
Posted Oct 23, 2025 - 16:54 UTC

Monitoring

We have fixed all our services. Our engineers will monitor the situation until we declare the incident resolved.
Posted Oct 23, 2025 - 16:52 UTC

Update

We have identified the issue and we are still working hard to fix it, some customers may still be experiencing issues.
Posted Oct 23, 2025 - 16:20 UTC

Identified

We have identified the cause of this incident and we are working to restore all the services as soon as possible.
Posted Oct 23, 2025 - 15:57 UTC

Investigating

We are experiencing issues with all the services.
Posted Oct 23, 2025 - 15:55 UTC
This incident affected: Global (Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV), Yoti Verified Calls) and USA1 (Identity verification, Age verification, Age estimation).