INC-2632

Incident Report for Yoti

Resolved

Some customers may have experienced delays sending emails to Yahoo-hosted email addresses (including Sky, AOL). Customers are advised to resend emails to these addresses by following https://vimeo.com/648543811
Posted Apr 29, 2022 - 11:18 UTC

Identified

We are experiencing delays sending emails to Yahoo-hosted email addresses (including Sky, AOL). Customers are advised to resend emails to these addresses by following https://vimeo.com/648543811
Posted Apr 29, 2022 - 10:55 UTC
This incident affected: Global (eSignatures).