INC-3490 (P3 - Low Priority)

Incident Report for Yoti

Resolved

The IDV and Digital ID services are fully operational. This incident has been resolved.
Posted Nov 07, 2025 - 00:44 UTC

Investigating

We are currently experiencing issues with Identity Profile checks within our IDV and Digital ID services. Some customers may receive error messages during this time.
Posted Nov 06, 2025 - 22:17 UTC
This incident affected: Global (Digital ID, Identity verification).