INC-3318 (P2- Medium Priority)

Incident Report for Yoti

Resolved

The service is fully operational. This incident has been resolved.
Posted Jun 05, 2025 - 12:53 UTC

Identified

The issue as been identified and fix is being implemented.
Posted Jun 05, 2025 - 12:02 UTC

Investigating

We are experiencing issues with uploading documents through web for eSignatures service.
Posted Jun 05, 2025 - 10:34 UTC
This incident affected: Global (eSignatures).