High volume of requests

Incident Report for Yoti

Resolved

The volume of requests are now back to normal level and all services are functioning correctly
Posted May 14, 2025 - 10:25 UTC

Investigating

We are experiencing a high volume of requests through our systems at the moment, some requests may take longer than normal
Posted May 13, 2025 - 09:36 UTC
This incident affected: Global (Digital ID, Identity verification).