INC-3674 (P1 - High Priority)

Incident Report for Yoti

Resolved

The services Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV), Yoti Verified Calls are fully operational. This incident has been resolved.
Posted Apr 10, 2026 - 13:00 UTC

Monitoring

We have fixed the Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV), Yoti Verified Calls services. Our engineers will monitor the situation until we declare the incident resolved.
Posted Apr 10, 2026 - 12:58 UTC

Investigating

We are experiencing issues with the Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV), Yoti Verified Calls services.
Posted Apr 10, 2026 - 12:38 UTC
This incident affected: Global (Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV), Yoti Verified Calls).