Slowness in admin checks
Incident Report for Yoti
Resolved
The Digital ID and Identity Verification services are fully operational. This incident has been resolved.
Posted May 29, 2024 - 18:47 UTC
Monitoring
We are getting some slowness in admin checks through the system that affects the Digital ID and Identity verification services. The checks are taking longer than normal
Posted May 29, 2024 - 16:44 UTC
This incident affected: Global (Digital ID, Identity verification).