INC-3620 (P1 | High Priority)

Incident Report for Yoti

Postmortem

Thursday 12th February 2026 from 15:05 UTC - 15:56 UTC

We are writing to provide an update concerning a temporary service interruption that affected Yoti services earlier today.

Our Network Operations Centre (NOC) identified a spike in error rates which, upon investigation, was found to be caused by a temporary fault within our traffic management systems.

This resulted in a period of unavailability for a number of our users. Our infrastructure team has since resolved the issue, and all services are now operating as normal.

We sincerely apologise for the inconvenience and disruption this outage may have caused. We are conducting a full investigation to identify improvements and prevent future recurrence.

Posted Feb 12, 2026 - 17:14 UTC

Resolved

The Digital ID, Identity verification, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, USA1 - Age verification, USA1 - Age estimation service is fully operational. This incident has been resolved.
Posted Feb 12, 2026 - 16:08 UTC

Monitoring

We have fixed the Digital ID, Identity verification, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, USA1 - Age verification, USA1 - Age estimation services. Our engineers will monitor the situation until we declare the incident resolved.
Posted Feb 12, 2026 - 16:05 UTC

Identified

We have identified the cause of this incident and we are working to restore the Digital ID, Identity verification, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, USA1 - Age verification, USA1 - Age estimation services as soon as possible.
Posted Feb 12, 2026 - 16:04 UTC

Update

We are continuing to investigate this issue.
Posted Feb 12, 2026 - 15:52 UTC

Investigating

We are experiencing issues with the Digital ID, Identity verification, Age estimation, eSignatures, Yoti Website services.
Posted Feb 12, 2026 - 15:24 UTC
This incident affected: Global (Digital ID, Identity verification, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website) and USA1 (Age verification, Age estimation).