The Digital ID and IDV service is now fully operational. The incident has been successfully resolved and all systems are stable. Thank you for your patience.
Posted Sep 24, 2026 - 14:15 UTC
Monitoring
A fix has been implemented for the Digital ID and IDV service, and we are seeing signs of recovery. Our team will continue to monitor the system closely to ensure stability before officially resolving the incident.
Posted Sep 24, 2026 - 14:10 UTC
Update
Some customers may encounter errors (5xx) when using our Digital ID or IDV service to complete RTW or DBS checks due to an issue with a third-party partner. We are actively working with their team to resolve this as quickly as possible.
Posted Sep 24, 2026 - 14:00 UTC
Update
Some customers may encounter errors (5xx) when using our Digital ID or IDV service to complete RTW or DBS checks due to an issue with a third-party partner. We are actively working with their team to resolve this as quickly as possible.
Posted Sep 24, 2026 - 13:13 UTC
Identified
Some customers may encounter errors (5xx) when using our Digital ID or IDV service to complete RTW or DBS checks due to an issue with a third-party partner. We are actively working with their team to resolve this as quickly as possible.
Posted Sep 24, 2026 - 12:52 UTC
This incident affected: Global (Digital ID, Identity verification).