INC-3727 (P2- Medium Priority)

Incident Report for Yoti

Postmortem

We are writing to provide an update regarding a temporary service disruption that affected Yoti services earlier today.

Our Network Operations Centre (NOC) identified a degradation affecting our Digital ID, Identity Verification, and In-Branch Verification (IBV) services. A prompt investigation revealed the root cause to be a temporary fault within our network management systems.

This issue resulted in a brief period of degraded performance for a number of our users. Our infrastructure team has since resolved the fault, and all services have been fully restored to normal operations.

We sincerely apologise for any inconvenience or disruption this incident may have caused. A comprehensive post-incident review is under way to identify system improvements and prevent future recurrences.

Posted May 19, 2026 - 16:55 UTC

Resolved

The Digital ID, Identity verification and IBV service is fully operational. This incident has been resolved.
Posted May 19, 2026 - 15:23 UTC

Monitoring

A fix has been implemented and our engineers are monitoring the issue until we declare the incident resolved.
Posted May 19, 2026 - 15:21 UTC

Identified

We are currently experiencing issues with Digital ID, Identity verification and UK post office IBV service. Our engineers are working on fix.
Posted May 19, 2026 - 15:00 UTC

Investigating

We are currently experiencing issues with UK post office IBV service.
Posted May 19, 2026 - 14:43 UTC
This incident affected: Global (Digital ID, Identity verification, UK Post Office In-branch verification (IBV)).