Incident-2755

Incident Report for Yoti

Resolved

The Identity verification, eSignatures, Yoti Hub, Yoti Website, Yoti Web Account services are fully operational. This incident has been resolved.
Posted Mar 30, 2023 - 05:59 UTC

Monitoring

We have fixed the Identity verification, eSignatures, Yoti Hub, Yoti Website, Yoti Web Account services. Our engineers will monitor the situation until we declare the incident resolved.
Posted Mar 30, 2023 - 05:57 UTC

Identified

We have identified the cause of this incident and we are working to restore the Identity verification, eSignatures, Yoti Hub, Yoti Website, Yoti Web Account services as soon as possible.
Posted Mar 30, 2023 - 05:40 UTC

Update

We are continuing to investigate this issue.
Posted Mar 30, 2023 - 05:35 UTC

Investigating

We are experiencing issues with the eSignatures, Yoti Hub, Yoti Website, Web Account, Yoti Webshare, IDV services.
Posted Mar 30, 2023 - 05:26 UTC
This incident affected: Global (Identity verification, eSignatures, Yoti Hub, Yoti Website, Yoti Web Account).