INC-2555

Incident Report for Yoti

Resolved

The eSignatures service is fully operational. This incident has been resolved.
Posted Jun 02, 2021 - 14:42 UTC

Monitoring

We have fixed the eSignatures service. Our engineers will monitor the situation until we declare the incident over.
Posted Jun 02, 2021 - 14:32 UTC

Investigating

We are experiencing performance issues with the eSignatures service. Customers may experience slowness in receiving completion emails.
Posted Jun 02, 2021 - 14:13 UTC
This incident affected: Global (eSignatures).