INC-3032 (P1 - High Priority)
Incident Report for Yoti
Postmortem

Wednesday 22nd May 2024 from 14:30 UTC - 16:22 UTC

The Yoti NOC team noticed an increase in error rate towards our Age estimation, Age verification, Identity verification portal, Identity verification, UK Post Office In-branch verification (IBV) services, Digital ID services.

The root cause was traced to an abdominal amount of requests received for our services, our infrastructure team quickly scaled up our services to mitigate against the impact.

Some impacted users may have been unable to access our services during this time.

Posted May 24, 2024 - 08:04 UTC

Resolved
The Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, and UK Post Office In-branch verification (IBV) service is fully operational. This incident has been resolved.
Posted May 22, 2024 - 16:11 UTC
Update
We are continuing to monitor for any further issues.
Posted May 22, 2024 - 16:01 UTC
Update
We are continuing to monitor for any further issues.
Posted May 22, 2024 - 16:00 UTC
Monitoring
We have fixed the Age estimation, Age verification, eSignatures, Digital ID and Identity verification services. Our engineers will monitor the situation until we declare the incident resolved.
Posted May 22, 2024 - 15:56 UTC
Investigating
We are still experiencing a degradation of the following services Age estimation, Age verification, eSignatures, Digital ID and Identity verification services.
Posted May 22, 2024 - 15:55 UTC
Update
We have fixed the Age estimation, Age verification,eSignatures, Digital ID and Identity verification services . Our engineers will monitor the situation until we declare the incident resolved
Posted May 22, 2024 - 15:47 UTC
Monitoring
We have fixed the Age estimation, Age verification and eSignatures services . Our engineers will monitor the situation until we declare the incident resolved.
Posted May 22, 2024 - 15:32 UTC
Update
We are experiencing issues with the Age estimation, Age verification and eSignatures services.
Posted May 22, 2024 - 15:24 UTC
Investigating
We are experiencing issues with the Age estimation service.
Posted May 22, 2024 - 14:50 UTC
This incident affected: Global (Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, UK Post Office In-branch verification (IBV)).