INC-3301 (P2- Medium Priority)

Incident Report for Yoti

Resolved

The service is fully operational. This incident has been resolved.
Posted May 14, 2025 - 04:58 UTC

Monitoring

We have fixed the issue. Our engineers will monitor the situation until we declare the incident resolved.
Posted May 14, 2025 - 04:52 UTC

Identified

We are aware customers may see error messages whilst using the postcode look up facility, identity cards and other official documents can still be used to verify your address. we are currently working on a fix to resolve this issue.
Posted May 14, 2025 - 00:12 UTC
This incident affected: Global (Digital ID).