INC-3324 (P1- High Priority )

Incident Report for Yoti

Postmortem

Friday 20th June 2025 from 12:18 UTC - 13:34 UTC

We are writing to inform you about a service interruption that occurred On Friday, impacting some of Yoti's products for customers in the London area.

Our Network Operations Center (NOC) team identified a major service outage with our primary Internet Service Provider (ISP) in London. This outage unfortunately prevented our secondary ISP from seamlessly taking over all traffic, due to the instability of the primary link. As a result, some of our products experienced temporary unavailability.

Our Infrastructure team responded immediately and quickly implemented changes to route all traffic over our secondary link. We are pleased to confirm that service has now been fully restored.

We sincerely apologise for any inconvenience this outage may have caused you. We understand the importance of reliable service and are reviewing this incident to further enhance the resilience of our network.

We apologise for any inconvenience this outage has caused our customers.

Posted Jun 23, 2025 - 05:15 UTC

Resolved

All services are fully operational. This incident has been resolved.
Posted Jun 20, 2025 - 13:34 UTC

Identified

We have identified the cause of this incident and we are working to restore the services as soon as possible.
Posted Jun 20, 2025 - 13:23 UTC

Update

We are continuing to investigate this issue.
Posted Jun 20, 2025 - 13:14 UTC

Update

We are continuing to investigate this issue.
Posted Jun 20, 2025 - 13:01 UTC

Investigating

We are experiencing intermittent issues with some of our services.
Posted Jun 20, 2025 - 12:18 UTC
This incident affected: Global (Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account) and USA1 (Identity verification, Age verification, Age estimation).