INC-3003 (P1 - High Priority)
Incident Report for Yoti
Postmortem

Wednesday 10th April 2024 from 15:55-16:06 UTC and 16:08-16:11 UTC

At 15:55 UTC, the Yoti NOC team noticed an increase in error rate towards our Digital ID, Identity verification, eSignatures and Yoti Web Account services.

The root cause was traced to a hardware failure in one of our data centres that caused a degradation of mentioned services at various intervals during the time of the incident as different parts of our systems recovered from the failure.

Impacted users would have noticed some slowness in the services or may have received generic 500 errors from Yoti’s backend systems.

Whereas the systems did recover automatically, Yoti’s infrastructure team stepped in and rerouted all services to another datacenter for faster recovery. The team is exploring options to recover from this kind of failure even faster in the future.

We apologise for any inconvenience this outage has caused our customers.

Posted Apr 11, 2024 - 16:51 UTC

Resolved
The Digital ID, Identity verification, eSignatures and Yoti Web Account are fully operational. This incident has been resolved.
Posted Apr 10, 2024 - 16:11 UTC
Monitoring
We have fixed the service (Digital ID, Identity verification, eSignatures and Yoti Web Account). Our engineers will monitor the situation until we declare the incident resolved.
Posted Apr 10, 2024 - 16:03 UTC
Investigating
We are experiencing issues with Digital ID, Identity verification, eSignatures and Yoti Web Account services.
Posted Apr 10, 2024 - 15:55 UTC
This incident affected: Global (Digital ID, Identity verification, eSignatures, Yoti Web Account).