INC-2627
Incident Report for Yoti
Resolved
This incident has been resolved.
Posted Dec 13, 2022 - 19:28 UTC
Identified
We experienced issues with the Identity verification service between 2022-12-13T18:40Z and 19:28Z.
Posted Dec 13, 2022 - 18:40 UTC
This incident affected: Canada (Identity verification).