INC-3576 (P2 - Medium Priority)

Incident Report for Yoti

Postmortem

Earlier today, some customers may have experienced errors (5xx) while accessing our services. This was due to a technical communication issue between our systems. Our monitoring alerts identified the spike immediately, and our engineering team has since resolved the issue.

We can confirm that all services are now fully operational, and we apologise for any inconvenience this may have caused to our customers.

Posted Jan 09, 2026 - 17:26 UTC

Resolved

The Digital ID, Identity verification, Identity verification portal and Yoti Web Account services are fully operational. This incident has been resolved.
Posted Jan 09, 2026 - 15:36 UTC

Monitoring

We believe the issues was an intermittent issues which has now been fixed. Our engineers will monitor the situation until we declare the incident resolved.
Posted Jan 09, 2026 - 15:35 UTC

Update

We are continuing to investigate the issue and some customers may see intermittent errors during this time.
Posted Jan 09, 2026 - 15:07 UTC

Investigating

We are experiencing issues with the Digital ID, Identity verification, Identity verification portal and Yoti Web Account service.
Posted Jan 09, 2026 - 14:21 UTC
This incident affected: Global (Digital ID, Identity verification, Identity verification portal, Yoti Web Account).