INC-3723 (P1 - High Priority)

Incident Report for Yoti

Update

Last night, Yoti experienced a targeted and sustained DDoS (denial of service) attack which impacted availability across parts of the Yoti platform.

Our security and engineering teams responded immediately and are working to restore all services.

We continue to monitor closely and will keep you informed of any further developments on this page.
Posted May 11, 2026 - 11:26 UTC

Update

Last night, Yoti experienced a targeted and sustained DDoS (denial of service) attack which impacted availability across parts of the Yoti platform.

Our security and engineering teams responded immediately and are working to restore all services.

We continue to monitor closely and will keep you informed of any further developments on this page.
Posted May 11, 2026 - 10:56 UTC

Update

Last night, Yoti experienced a targeted and sustained DDoS (denial of service) attack which impacted availability across parts of the Yoti platform.

Our security and engineering teams responded immediately and are working to restore all services.

We continue to monitor closely and will keep you informed of any further developments on this page.
Posted May 11, 2026 - 10:10 UTC

Update

Last night, Yoti experienced a targeted and sustained DDoS (denial of service) attack which impacted availability across parts of the Yoti platform.

Our security and engineering teams responded immediately and are working to restore all services.

We continue to monitor closely and will keep you informed of any further developments on this page
Posted May 11, 2026 - 09:40 UTC

Update

Last night, Yoti experienced a targeted and sustained DDoS (denial of service) attack which impacted availability across parts of the Yoti platform.

Our security and engineering teams responded immediately and are working to restore all services.

We continue to monitor closely and will keep you informed of any further developments on this page
Posted May 11, 2026 - 09:07 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 08:40 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 08:10 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 07:39 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 07:10 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 06:40 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 06:11 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 05:40 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 05:10 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 04:40 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 04:10 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 03:40 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 03:10 UTC

Update

We are aware of an ongoing network-level incident affecting service availability for some customers. Mitigations have been applied and service has been substantially restored, however residual impact may still be observed in the form of intermittent timeouts or degraded performance.
Posted May 11, 2026 - 02:40 UTC

Update

Service restoration is currently underway for most users. We appreciate your patience as we finalise the fix.
Posted May 11, 2026 - 02:14 UTC

Update

Service restoration is currently underway for most users. We appreciate your patience as we finalise the fix.
Posted May 11, 2026 - 01:19 UTC

Update

Service restoration is currently underway for most users. We appreciate your patience as we finalise the fix.
Posted May 11, 2026 - 00:49 UTC

Identified

Service restoration is currently underway for most users. We appreciate your patience as we finalise the fix.
Posted May 11, 2026 - 00:20 UTC

Update

we are still experiencing issues with all Yoti services.
Posted May 11, 2026 - 00:11 UTC

Update

we are still experiencing issues with all Yoti services.
Posted May 10, 2026 - 23:41 UTC

Update

We are experiencing issues with all our services.
Posted May 10, 2026 - 23:15 UTC

Update

we are still experiencing issues with all Yoti services.
Posted May 10, 2026 - 22:43 UTC

Update

we are still experiencing issues with all Yoti services.
Posted May 10, 2026 - 22:14 UTC

Update

we are still experiencing issues with all Yoti services.
Posted May 10, 2026 - 21:42 UTC

Update

we are still experiencing issues with all Yoti services.
Posted May 10, 2026 - 21:11 UTC

Update

we are still experiencing issues with all Yoti services.
Posted May 10, 2026 - 20:41 UTC

Investigating

We are experiencing issues with all our services.
Posted May 10, 2026 - 20:12 UTC
This incident affects: Global (Digital ID, Identity verification, Identity verification portal, Age verification, Age estimation, eSignatures, Yoti Hub, Yoti Website, Yoti Password Manager, Yoti Web Account, UK Post Office In-branch verification (IBV), Yoti Verified Calls, Credentials) and USA1 (Identity verification, Age verification, Age estimation).