INC-2667
Incident Report for Yoti
Resolved
The Security Center is fully operational. This incident has been resolved.
Posted Sep 09, 2022 - 21:21 UTC
Monitoring
The delay in our Security Center is fixed.
Posted Sep 09, 2022 - 21:12 UTC
Investigating
We are experiencing minor delay in our Security Center.
Posted Sep 09, 2022 - 18:10 UTC
This incident affected: Global (Digital ID, Identity verification).